PHP 4.xでPHP 5.2/6.0の機能を実現する互換キット

PHP

PHP 4.xでPHP 5.2/6.0の機能を実現する互換キット"upgrade.php 15"登場 | エンタープライズ | マイコミジャーナル
2007年7月31日(ドイツ時間)、upgrade.phpの最新版となる「upgrade.php 15」が公開された。upgrade.phpはPHPで開発された後方互換実現のためのコンパチブルキット。パブリックドメインとして公開されている。PHP 5.2や6.0で導入された新しいコア関数をPHP 4.xで動作するように実装したプロダクトで、4.x系で5.2や6.0で導入された機能を使いたい場合に役に立つ。

こんな素敵なライブラリがあったんですね。
php5.2で追加されたjson_decodeとかjson_encodeって便利なのですが、
基本4.xをターゲットにしていたために、使っていませんでした。
他にもxmlがらみも簡単にできそうですね。。
これをincludeすることによってどの程度の速度低下になるかがわかりませんが、
ほとんど変わらないなら、いいかもしれません。

今度試してみよっと。

php
 
 

Newer: pplog premium beta 2

Older: 新PC。

in the PHP category...

Newer: phpでitunes操作

Older: ひさしぶりに新スクリプト

他にもこんな記事が読まれています [さらに他の記事]

Copyright © 2004 - 2017 Rocomotion All Rights Reserved.